Dashboard Interface malfunction

Incident

Dashboard Interface malfunction

Status: closed
Start:
End:
Duration: 29 minutes
Affected Components:
Merchant Portal
Update

Dear Client,


Please note that Merchant interface portal.payabl.com is partly unavailable.
Transactions pass without interruptions, no production processing is affected.

You may face issues with login into Interface, our IT team is already on it!

Resolved

payabl. Dashboard portal is operating normally.
No Transactions processing was affected, the issue was located on interface level.

we apologize for inconveniences caused and keep the system under monitoring.