Scheduled Third-Party Maintenance Notification

Scheduled

Scheduled Third-Party Maintenance Notification

Status: closed
Start:
End:
Duration: 15 minutes
Affected Components:
Alternative Payment methods EPS
Update

Dear Merchant/Partner,

We’ve been informed of a scheduled maintenance by EPS which may impact payment processing during the following window:

Start Date: [August 06, 2025, 19:00 PM EET]
End Date: [August 06, 2025, 19:15 PM EET]

We appreciate your understanding and will keep you informed if further updates are needed. If you experience any issues that persist beyond the maintenance period, please do not hesitate to contact us.

Resolved

Please know that the scheduled Third-Party maintenance is completed.