Scheduled Third-Party Maintenance Notification

Scheduled

Scheduled Third-Party Maintenance Notification

Status: closed
Start:
End:
Duration: 2 hours
Affected Components:
Payment Processor: Visa/Mastercard Alternative Payment methods Hosted Payment Page Apple Pay EPS Google Pay Instant Bank Transfer Bancontact PaysafeCard Sofort Trustly Payment Processor: Other APMs
Update

Dear Merchant/Partner,

We’ve been informed of a scheduled maintenance by a Third-Party partner during the following window. No downtime is expected.

Start Date: [September 3, 2025, 10:00 AM EEST]
End Date: [September 3, 2025, 12:00 AM EEST]

We appreciate your understanding and will keep you informed if further updates are needed. Should you experience any issues during this time, please do not hesitate to contact us.

Resolved

Please know that the Third-Party maintenance is now completed.