Service Disruption
Incident
2025-09-05T11:58:00.0000000Z
Service Disruption
Status: closed
Start:
2025-09-05T11:28:00.0000000Z
End:
2025-09-05T11:58:00.0000000Z
Duration: 30 minutes
Affected Components:
Payment Processor: Visa/Mastercard
Alternative Payment methods
Hosted Payment Page
Merchant Portal
Apple Pay
EPS
Google Pay
Instant Bank Transfer
Bancontact
PaysafeCard
Sofort
Trustly
Payment Processor: Other APMs
Update
2025-09-05T11:28:00.0000000Z
2025-09-05T11:28:00.0000000Z
Dear Merchant/Partner,
Please know that we have identified an issue that is currently affecting our services. Our team is working urgently to resolve the issue. We appreciate your patience during this time.
We will keep you updated as we work towards a solution.
Resolved
2025-09-05T11:58:00.0000000Z
2025-09-05T11:58:00.0000000Z
Dear Merchant/Partner,
Please know that the service disruption has been resolved and all systems are now fully operational.
Thank you for your patience
Copyright (C) 2021.