Partial Service Disruption
Incident
2025-11-04T15:13:00.0000000Z
Partial Service Disruption
Status: closed
Start:
2025-11-04T14:34:00.0000000Z
End:
2025-11-04T15:13:00.0000000Z
Duration: 39 minutes
Affected Components:
Payment Processor: Visa/Mastercard
Alternative Payment methods
Apple Pay
EPS
Google Pay
Instant Bank Transfer
Bancontact
PaysafeCard
Sofort
Trustly
Payment Processor: Other APMs
Update
2025-11-04T14:34:00.0000000Z
2025-11-04T14:34:00.0000000Z
Dear Merchant/Partner,
Please know that we are experiencing a partial disruption affecting our services. Our team is working urgently to resolve the issue. We appreciate your patience during this time.
We will keep you updated as we work towards a solution.
Resolved
2025-11-04T15:13:00.0000000Z
2025-11-04T15:13:00.0000000Z
Dear Merchant/Partner,
Please know that the service disruption has been resolved and all systems are now fully operational. We keep monitoring our systems.
Thank you for your patience
Copyright (C) 2021.