Partial Service Disruption
Incident
2025-11-29T07:38:00.0000000Z
Partial Service Disruption
Status: closed
Start:
2025-11-29T07:31:00.0000000Z
End:
2025-11-29T07:38:00.0000000Z
Duration: 7 minutes
Affected Components:
Payment Processor: Visa/Mastercard
Alternative Payment methods
Hosted Payment Page
Merchant Portal
Merchant Sandbox
Banking System
POS processing
Apple Pay
EPS
Google Pay
Instant Bank Transfer
Bancontact
PaysafeCard
Sofort
Trustly
Payment Processor: Other APMs
Update
2025-11-29T07:31:00.0000000Z
2025-11-29T07:31:00.0000000Z
Dear Merchant/Partner,
Please know that we are experiencing a partial disruption affecting our services. Our team resolved the issue within 7 minutes.
We apologize for any inconvenience caused.
Resolved
2025-11-29T07:38:00.0000000Z
2025-11-29T07:38:00.0000000Z
Kindly note that all services were restored and processing is as expected.
Copyright (C) 2021.