Service Disruption: processing services are affected

Incident

Service Disruption: processing services are affected

Status: closed
Start:
End:
Duration: 55 minutes
Affected Components:
Payment Processor: Visa/Mastercard Alternative Payment methods Hosted Payment Page Merchant Portal Merchant Sandbox Banking System POS processing Apple Pay EPS Google Pay Instant Bank Transfer Bancontact PaysafeCard Sofort Trustly Payment Processor: Other APMs
Update

Dear Merchant/Partner,


We are currently experiencing an issue affecting payabl. processing domains, which may result in service disruptions. As a consequence, Payment processing and Dashboard in the production environment is currently impacted.

Our technical team is actively investigating and working to resolve the issue as quickly as possible. We will continue to provide updates as more information becomes available.

Resolved

We are seeing recovery in traffic levels, and processing is returning to normal.

The preliminary cause appears to be a global outage affecting our vendor Cloud services, which impacted our systems. We apologize for the disruption and appreciate your patience while we worked through the issue.

We will provide additional updates if new details become available or if there are any changes in status.