Mastercard | Third-Party Service Disruption

Incident

Mastercard | Third-Party Service Disruption

Status: closed
Start:
End:
Duration: 3 hours 17 minutes
Affected Components:
Payment Processor: Visa/Mastercard
Update

Dear Merchant/Partner,


Mastercard has informed us of an active issue currently affecting their services. As a result, end-users might experience an increase in timeouts, delayed processing, or unexpected declines for Mastercard transactions.


Please note that this issue is isolated to Mastercard. All other payment networks are processing normally.

Resolved

Dear Merchant/Partner,

Mastercard has confirmed that the network issue reported yesterday was fully resolved.

All Mastercard transactions are processing normally, and end-users should no longer experience the elevated timeouts, delayed processing, or unexpected declines.

Thank you for your patience and cooperation.